Rapid7 Vulnerability & Exploit Database

Huawei EulerOS: CVE-2019-10164: postgresql security update

Back to Search

Huawei EulerOS: CVE-2019-10164: postgresql security update

Severity
9
CVSS
(AV:N/AC:L/Au:S/C:C/I:C/A:C)
Published
06/26/2019
Created
08/29/2019
Added
08/28/2019
Modified
08/28/2019

Description

PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a stack-based buffer by changing the user's own password to a purpose-crafted value. This often suffices to execute arbitrary code as the PostgreSQL operating system account.

Solution(s)

  • huawei-euleros-2_0_sp8-upgrade-postgresql
  • huawei-euleros-2_0_sp8-upgrade-postgresql-contrib
  • huawei-euleros-2_0_sp8-upgrade-postgresql-devel
  • huawei-euleros-2_0_sp8-upgrade-postgresql-docs
  • huawei-euleros-2_0_sp8-upgrade-postgresql-libs
  • huawei-euleros-2_0_sp8-upgrade-postgresql-plperl
  • huawei-euleros-2_0_sp8-upgrade-postgresql-plpython
  • huawei-euleros-2_0_sp8-upgrade-postgresql-pltcl
  • huawei-euleros-2_0_sp8-upgrade-postgresql-server
  • huawei-euleros-2_0_sp8-upgrade-postgresql-test

References

  • huawei-euleros-2_0_sp8-upgrade-postgresql
  • huawei-euleros-2_0_sp8-upgrade-postgresql-contrib
  • huawei-euleros-2_0_sp8-upgrade-postgresql-devel
  • huawei-euleros-2_0_sp8-upgrade-postgresql-docs
  • huawei-euleros-2_0_sp8-upgrade-postgresql-libs
  • huawei-euleros-2_0_sp8-upgrade-postgresql-plperl
  • huawei-euleros-2_0_sp8-upgrade-postgresql-plpython
  • huawei-euleros-2_0_sp8-upgrade-postgresql-pltcl
  • huawei-euleros-2_0_sp8-upgrade-postgresql-server
  • huawei-euleros-2_0_sp8-upgrade-postgresql-test

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;