Rapid7 Vulnerability & Exploit Database

Jenkins Advisory 2017-02-01: CVE-2017-2612: Low privilege users were able to override JDK download credentials

Back to Search

Jenkins Advisory 2017-02-01: CVE-2017-2612: Low privilege users were able to override JDK download credentials

Severity
6
CVSS
(AV:N/AC:L/Au:S/C:N/I:P/A:P)
Published
11/13/2017
Created
07/25/2018
Added
11/13/2017
Modified
07/03/2018

Description

In Jenkins before versions 2.44, 2.32.2 low privilege users were able to override JDK download credentials (SECURITY-392), resulting in future builds possibly failing to download a JDK.

Solution(s)

  • jenkins-lts-upgrade-2_32_2
  • jenkins-upgrade-2_44

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;