Vulnerability & Exploit Database

Back to search

Jenkins Advisory 2017-10-11: CVE-2017-1000393: Arbitrary shell command execution on master by users with Agent-related permissions

Severity CVSS Published Added Modified
4 (AV:L/AC:M/Au:N/C:P/I:P/A:P) November 19, 2017 November 19, 2017 November 19, 2017

Description

Users with permission to create or configure agents in Jenkins could configure a called . This allowed them to run arbitrary shell commands on the master node whenever the agent was supposed to be launched.Configuration of this launch method now requires the permission typically only granted to administrators.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

jenkins-lts-upgrade-2_73_2

Related Vulnerabilities