Rapid7 Vulnerability & Exploit Database

Moodle: (CVE-2019-3809): MSA-19-0002: Blind SSRF Risk in /badges/mybackpack.php

Back to Search

Moodle: (CVE-2019-3809): MSA-19-0002: Blind SSRF Risk in /badges/mybackpack.php

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
01/21/2019
Created
03/19/2019
Added
01/21/2019
Modified
05/05/2019

Description

A flaw was found in Moodle versions 3.1 to 3.1.15 and earlier unsupported versions. The mybackpack functionality allowed setting the URL of badges, when it should be restricted to the Mozilla Open Badges backpack URL. This resulted in the possibility of blind SSRF via requests made by the page.

Solution(s)

  • moodle-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;