Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2017-0898: Vulnerability in Ruby

Back to Search

Oracle Solaris 11: CVE-2017-0898: Vulnerability in Ruby

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
09/15/2017
Created
03/19/2019
Added
02/20/2019
Modified
11/17/2021

Description

Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

Solution(s)

  • oracle-solaris-11-4-upgrade-value-runtime-ruby-23-2-3-8-11-4-6-0-1-1-0
  • oracle-solaris-11-4-upgrade-value-runtime-ruby-23-ruby-tk-2-3-8-11-4-6-0-1-1-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;