Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2019-15903: Vulnerability in Firefox, Python, Thunderbird, libexpat

Back to Search

Oracle Solaris 11: CVE-2019-15903: Vulnerability in Firefox, Python, Thunderbird, libexpat

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
09/04/2019
Created
11/21/2019
Added
11/20/2019
Modified
01/19/2022

Description

In libexpat before 2.2.8, crafted XML input could fool the parser into changing from DTD parsing to document parsing too early; a consecutive call to XML_GetCurrentLineNumber (or XML_GetCurrentColumnNumber) then resulted in a heap-based buffer over-read.

Solution(s)

  • oracle-solaris-11-4-upgrade-value-library-expat-2-2-9-11-4-16-0-1-1-0
  • oracle-solaris-11-4-upgrade-value-library-python-tkinter-27-2-7-17-11-4-16-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-mail-thunderbird-68-2-0-11-4-15-0-1-4-0
  • oracle-solaris-11-4-upgrade-value-mail-thunderbird-plugin-thunderbird-lightning-68-2-0-11-4-15-0-1-4-0
  • oracle-solaris-11-4-upgrade-value-runtime-python-27-2-7-17-11-4-16-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-runtime-python-27-tests-2-7-17-11-4-16-0-1-2-0
  • oracle-solaris-11-4-upgrade-value-web-browser-firefox-68-2-0-11-4-15-0-1-4-0
  • oracle-solaris-11-4-upgrade-value-web-data-firefox-bookmarks-68-2-0-11-4-15-0-1-4-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;