Rapid7 Vulnerability & Exploit Database

Oracle Solaris 11: CVE-2019-19956: Vulnerability in libxml2

Back to Search

Oracle Solaris 11: CVE-2019-19956: Vulnerability in libxml2

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
12/24/2019
Created
01/20/2021
Added
01/19/2021
Modified
11/17/2021

Description

xmlParseBalancedChunkMemoryRecover in parser.c in libxml2 before 2.9.10 has a memory leak related to newDoc->oldNs.

Solution(s)

  • oracle-solaris-11-4-upgrade-value-legacy-library-python-libxml2-34-2-9-9-11-4-21-0-1-69-0
  • oracle-solaris-11-4-upgrade-value-library-libxml2-2-9-9-11-4-21-0-1-69-0
  • oracle-solaris-11-4-upgrade-value-library-python-2-libxml2-26-2-9-4-11-4-0-0-0-13-0
  • oracle-solaris-11-4-upgrade-value-library-python-2-libxml2-27-2-9-1-11-4-0-0-1-9-0
  • oracle-solaris-11-4-upgrade-value-library-python-libxml2-26-2-9-4-11-4-0-0-1-9-0
  • oracle-solaris-11-4-upgrade-value-library-python-libxml2-27-2-9-9-11-4-21-0-1-69-0
  • oracle-solaris-11-4-upgrade-value-library-python-libxml2-34-2-9-9-11-4-21-0-1-69-0
  • oracle-solaris-11-4-upgrade-value-library-python-libxml2-37-2-9-9-11-4-21-0-1-69-0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;