Rapid7 Vulnerability & Exploit Database

Oracle Linux: (CVE-2018-10893) (Multiple Advisories): spice-gtk security update

Back to Search

Oracle Linux: (CVE-2018-10893) (Multiple Advisories): spice-gtk security update

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
08/31/2018
Created
02/14/2020
Added
02/12/2020
Modified
07/21/2020

Description

Multiple integer overflow and buffer overflow issues were discovered in spice-client's handling of LZ compressed frames. A malicious server could cause the client to crash or, potentially, execute arbitrary code.

Solution(s)

  • oracle-linux-upgrade-libgovirt
  • oracle-linux-upgrade-libgovirt-devel
  • oracle-linux-upgrade-spice-glib
  • oracle-linux-upgrade-spice-glib-devel
  • oracle-linux-upgrade-spice-gtk
  • oracle-linux-upgrade-spice-gtk-devel
  • oracle-linux-upgrade-spice-gtk-python
  • oracle-linux-upgrade-spice-gtk-tools
  • oracle-linux-upgrade-spice-gtk3
  • oracle-linux-upgrade-spice-gtk3-devel
  • oracle-linux-upgrade-spice-gtk3-vala
  • oracle-linux-upgrade-spice-vdagent
  • oracle-linux-upgrade-virt-viewer

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;