Rapid7 Vulnerability & Exploit Database

phpMyAdmin: Cross-Site Request Forgery (CSRF) (CVE-2018-19969)

Back to Search

phpMyAdmin: Cross-Site Request Forgery (CSRF) (CVE-2018-19969)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
12/11/2018
Created
10/23/2019
Added
10/16/2019
Modified
10/16/2019

Description

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

Solution(s)

  • phpmyadmin-upgrade-4_8_4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;