Rapid7 Vulnerability & Exploit Database

PostgreSQL: CVE-2017-7548: lo_put() function ignores ACLs

Back to Search

PostgreSQL: CVE-2017-7548: lo_put() function ignores ACLs

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:P/A:N)
Published
08/16/2017
Created
07/25/2018
Added
08/17/2017
Modified
02/12/2021

Description

PostgreSQL versions before 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers with no privileges on a large object to overwrite the entire contents of the object, resulting in a denial of service.

Solution(s)

  • postgres-upgrade-9_6_4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;