Rapid7 Vulnerability & Exploit Database

PostgreSQL: CVE-2021-32027: Buffer overrun from integer overflow in array subscripting calculations

Back to Search

PostgreSQL: CVE-2021-32027: Buffer overrun from integer overflow in array subscripting calculations

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:P/I:P/A:P)
Published
05/14/2021
Created
05/15/2021
Added
05/14/2021
Modified
11/11/2022

Description

A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

Solution(s)

  • postgres-upgrade-11_12
  • postgres-upgrade-12_7
  • postgres-upgrade-13_3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;