Rapid7 Vulnerability & Exploit Database

Red Hat OpenShift: CVE-2019-10320: jenkins-credentials-plugin: Certificate file read vulnerability in Credentials Plugin (SECURITY-1322)

Back to Search

Red Hat OpenShift: CVE-2019-10320: jenkins-credentials-plugin: Certificate file read vulnerability in Credentials Plugin (SECURITY-1322)

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
05/21/2019
Created
07/05/2019
Added
07/04/2019
Modified
07/04/2019

Description

Jenkins Credentials Plugin 2.1.18 and earlier allowed users with permission to create or update credentials to confirm the existence of files on the Jenkins master with an attacker-specified path, and obtain the certificate content of files containing a PKCS#12 certificate.

Solution(s)

  • linuxrpm-upgrade-jenkins-2-plugins

References

  • linuxrpm-upgrade-jenkins-2-plugins

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;