Rapid7 Vulnerability & Exploit Database

Red Hat OpenShift: CVE-2022-30952: Jenkins plugin: User-scoped credentials exposed to other users by Pipeline SCM API for Blue Ocean Plugin

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Red Hat OpenShift: CVE-2022-30952: Jenkins plugin: User-scoped credentials exposed to other users by Pipeline SCM API for Blue Ocean Plugin

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
05/17/2022
Created
01/14/2023
Added
01/13/2023
Modified
03/27/2024

Description

Jenkins Pipeline SCM API for Blue Ocean Plugin 1.25.3 and earlier allows attackers with Job/Configure permission to access credentials with attacker-specified IDs stored in the private per-user credentials stores of any attacker-specified user in Jenkins.

Solution(s)

  • linuxrpm-upgrade-jenkins-2-plugins

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;