Vulnerability & Exploit Database

Back to search

Apache Struts: CVE-2016-1182: XSS and denial of service

Severity CVSS Published Added Modified
6 (AV:N/AC:L/Au:N/C:N/I:P/A:P) July 03, 2016 June 26, 2017 October 29, 2017

Description

ActionServlet.java in Apache Struts 1 1.x through 1.3.10 does not properly restrict the Validator configuration, which allows remote attackers to conduct cross-site scripting (XSS) attacks or cause a denial of service via crafted input, a related issue to CVE-2015-0899.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

struts-cve-2016-1182-1

Related Vulnerabilities