Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2015-8869: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2015-8869: SUSE Linux Security Advisory

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
06/13/2016
Created
07/25/2018
Added
06/13/2016
Modified
02/04/2022

Description

OCaml before 4.03.0 does not properly handle sign extensions, which allows remote attackers to conduct buffer overflow attacks or obtain sensitive information as demonstrated by a long string to the String.copy function.

Solution(s)

  • suse-upgrade-ocaml
  • suse-upgrade-ocaml-compiler-libs
  • suse-upgrade-ocaml-compiler-libs-devel
  • suse-upgrade-ocaml-ocamldoc
  • suse-upgrade-ocaml-rpm-macros
  • suse-upgrade-ocaml-runtime

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;