Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2017-1000445: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2017-1000445: SUSE Linux Security Advisory

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
01/02/2018
Created
07/25/2018
Added
01/10/2018
Modified
05/07/2019

Description

ImageMagick 7.0.7-1 and older version are vulnerable to null pointer dereference in the MagickCore component and might lead to denial of service

Solution(s)

  • suse-upgrade-imagemagick
  • suse-upgrade-imagemagick-debuginfo
  • suse-upgrade-imagemagick-debugsource
  • suse-upgrade-imagemagick-devel
  • suse-upgrade-imagemagick-devel-32bit
  • suse-upgrade-imagemagick-doc
  • suse-upgrade-imagemagick-extra
  • suse-upgrade-imagemagick-extra-debuginfo
  • suse-upgrade-libmagick-1
  • suse-upgrade-libmagick-6_q16-3
  • suse-upgrade-libmagick-6_q16-3-32bit
  • suse-upgrade-libmagick-6_q16-3-debuginfo
  • suse-upgrade-libmagick-6_q16-3-debuginfo-32bit
  • suse-upgrade-libmagick-devel
  • suse-upgrade-libmagick-devel-32bit
  • suse-upgrade-libmagickcore-6_q16-1
  • suse-upgrade-libmagickcore-6_q16-1-32bit
  • suse-upgrade-libmagickcore-6_q16-1-debuginfo
  • suse-upgrade-libmagickcore-6_q16-1-debuginfo-32bit
  • suse-upgrade-libmagickcore1
  • suse-upgrade-libmagickcore1-32bit
  • suse-upgrade-libmagickwand-6_q16-1
  • suse-upgrade-libmagickwand-6_q16-1-32bit
  • suse-upgrade-libmagickwand-6_q16-1-debuginfo
  • suse-upgrade-libmagickwand-6_q16-1-debuginfo-32bit
  • suse-upgrade-libmagickwand1
  • suse-upgrade-libmagickwand1-32bit
  • suse-upgrade-perl-perlmagick
  • suse-upgrade-perl-perlmagick-debuginfo

References

  • suse-upgrade-imagemagick
  • suse-upgrade-imagemagick-debuginfo
  • suse-upgrade-imagemagick-debugsource
  • suse-upgrade-imagemagick-devel
  • suse-upgrade-imagemagick-devel-32bit
  • suse-upgrade-imagemagick-doc
  • suse-upgrade-imagemagick-extra
  • suse-upgrade-imagemagick-extra-debuginfo
  • suse-upgrade-libmagick-1
  • suse-upgrade-libmagick-6_q16-3
  • suse-upgrade-libmagick-6_q16-3-32bit
  • suse-upgrade-libmagick-6_q16-3-debuginfo
  • suse-upgrade-libmagick-6_q16-3-debuginfo-32bit
  • suse-upgrade-libmagick-devel
  • suse-upgrade-libmagick-devel-32bit
  • suse-upgrade-libmagickcore-6_q16-1
  • suse-upgrade-libmagickcore-6_q16-1-32bit
  • suse-upgrade-libmagickcore-6_q16-1-debuginfo
  • suse-upgrade-libmagickcore-6_q16-1-debuginfo-32bit
  • suse-upgrade-libmagickcore1
  • suse-upgrade-libmagickcore1-32bit
  • suse-upgrade-libmagickwand-6_q16-1
  • suse-upgrade-libmagickwand-6_q16-1-32bit
  • suse-upgrade-libmagickwand-6_q16-1-debuginfo
  • suse-upgrade-libmagickwand-6_q16-1-debuginfo-32bit
  • suse-upgrade-libmagickwand1
  • suse-upgrade-libmagickwand1-32bit
  • suse-upgrade-perl-perlmagick
  • suse-upgrade-perl-perlmagick-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;