Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2017-2885: SUSE Linux Security Advisory

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

SUSE: CVE-2017-2885: SUSE Linux Security Advisory

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
08/10/2017
Created
07/25/2018
Added
08/10/2017
Modified
06/20/2021

Description

An exploitable stack based buffer overflow vulnerability exists in the GNOME libsoup 2.58. A specially crafted HTTP request can cause a stack overflow resulting in remote code execution. An attacker can send a special HTTP request to the vulnerable server to trigger this vulnerability.

Solution(s)

  • suse-upgrade-libsoup-2_4-1
  • suse-upgrade-libsoup-2_4-1-32bit
  • suse-upgrade-libsoup-devel
  • suse-upgrade-libsoup-lang
  • suse-upgrade-typelib-1_0-soup-2_4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;