Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2017-5946: SUSE Linux Security Advisory

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

SUSE: CVE-2017-5946: SUSE Linux Security Advisory

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
02/27/2017
Created
07/25/2018
Added
08/10/2017
Modified
05/10/2021

Description

The Zip::File component in the rubyzip gem before 1.2.1 for Ruby has a directory traversal vulnerability. If a site allows uploading of .zip files, an attacker can upload a malicious file that uses "../" pathname substrings to write arbitrary files to the filesystem.

Solution(s)

  • suse-upgrade-ruby2-1-rubygem-rubyzip
  • suse-upgrade-ruby2-1-rubygem-rubyzip-doc
  • suse-upgrade-ruby2-1-rubygem-rubyzip-testsuite
  • suse-upgrade-ruby2-2-rubygem-rubyzip
  • suse-upgrade-ruby2-2-rubygem-rubyzip-doc
  • suse-upgrade-ruby2-2-rubygem-rubyzip-testsuite
  • suse-upgrade-ruby2-3-rubygem-rubyzip
  • suse-upgrade-ruby2-3-rubygem-rubyzip-doc
  • suse-upgrade-ruby2-3-rubygem-rubyzip-testsuite
  • suse-upgrade-ruby2-4-rubygem-rubyzip
  • suse-upgrade-ruby2-4-rubygem-rubyzip-doc
  • suse-upgrade-ruby2-4-rubygem-rubyzip-testsuite

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;