Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2017-7547: SUSE Linux Security Advisory

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

SUSE: CVE-2017-7547: SUSE Linux Security Advisory

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:P/I:N/A:N)
Published
08/10/2017
Created
07/25/2018
Added
08/23/2017
Modified
06/20/2021

Description

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by the foreign server owners without actually having the privileges to do so.

Solution(s)

  • suse-upgrade-libecpg6
  • suse-upgrade-libpq5
  • suse-upgrade-libpq5-32bit
  • suse-upgrade-postgresql10
  • suse-upgrade-postgresql10-contrib
  • suse-upgrade-postgresql10-devel
  • suse-upgrade-postgresql10-docs
  • suse-upgrade-postgresql10-plperl
  • suse-upgrade-postgresql10-plpython
  • suse-upgrade-postgresql10-pltcl
  • suse-upgrade-postgresql10-server
  • suse-upgrade-postgresql93
  • suse-upgrade-postgresql93-contrib
  • suse-upgrade-postgresql93-docs
  • suse-upgrade-postgresql93-server
  • suse-upgrade-postgresql94
  • suse-upgrade-postgresql94-contrib
  • suse-upgrade-postgresql94-devel
  • suse-upgrade-postgresql94-docs
  • suse-upgrade-postgresql94-server
  • suse-upgrade-postgresql96
  • suse-upgrade-postgresql96-contrib
  • suse-upgrade-postgresql96-devel
  • suse-upgrade-postgresql96-docs
  • suse-upgrade-postgresql96-server

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;