Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2017-7668: SUSE Linux Security Advisory

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

SUSE: CVE-2017-7668: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
06/20/2017
Created
07/25/2018
Added
10/30/2017
Modified
04/25/2022

Description

The HTTP strict parsing changes added in Apache httpd 2.2.32 and 2.4.24 introduced a bug in token list parsing, which allows ap_find_token() to search past the end of its input string. By maliciously crafting a sequence of request headers, an attacker may be able to cause a segmentation fault, or to force ap_find_token() to return an incorrect value.

Solution(s)

  • suse-upgrade-apache2
  • suse-upgrade-apache2-devel
  • suse-upgrade-apache2-doc
  • suse-upgrade-apache2-example-pages
  • suse-upgrade-apache2-prefork
  • suse-upgrade-apache2-utils
  • suse-upgrade-apache2-worker

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;