Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2018-10851: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2018-10851: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
11/06/2018
Created
03/19/2019
Added
12/18/2018
Modified
10/22/2021

Description

PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.

Solution(s)

  • suse-upgrade-pdns
  • suse-upgrade-pdns-backend-geoip
  • suse-upgrade-pdns-backend-godbc
  • suse-upgrade-pdns-backend-ldap
  • suse-upgrade-pdns-backend-lua
  • suse-upgrade-pdns-backend-mydns
  • suse-upgrade-pdns-backend-mysql
  • suse-upgrade-pdns-backend-postgresql
  • suse-upgrade-pdns-backend-remote
  • suse-upgrade-pdns-backend-sqlite3
  • suse-upgrade-pdns-recursor

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;