Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2018-10918: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2018-10918: SUSE Linux Security Advisory

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
08/14/2018
Created
03/19/2019
Added
08/18/2018
Modified
02/04/2022

Description

A null pointer dereference flaw was found in the way samba checked database outputs from the LDB database layer. An authenticated attacker could use this flaw to crash a samba server in an Active Directory Domain Controller configuration. Samba versions before 4.7.9 and 4.8.4 are vulnerable.

Solution(s)

  • suse-upgrade-ctdb
  • suse-upgrade-ctdb-pcp-pmda
  • suse-upgrade-ctdb-tests
  • suse-upgrade-libdcerpc-binding0
  • suse-upgrade-libdcerpc-binding0-32bit
  • suse-upgrade-libdcerpc-devel
  • suse-upgrade-libdcerpc-samr-devel
  • suse-upgrade-libdcerpc-samr0
  • suse-upgrade-libdcerpc-samr0-32bit
  • suse-upgrade-libdcerpc0
  • suse-upgrade-libdcerpc0-32bit
  • suse-upgrade-libndr-devel
  • suse-upgrade-libndr-krb5pac-devel
  • suse-upgrade-libndr-krb5pac0
  • suse-upgrade-libndr-krb5pac0-32bit
  • suse-upgrade-libndr-nbt-devel
  • suse-upgrade-libndr-nbt0
  • suse-upgrade-libndr-nbt0-32bit
  • suse-upgrade-libndr-standard-devel
  • suse-upgrade-libndr-standard0
  • suse-upgrade-libndr-standard0-32bit
  • suse-upgrade-libndr0
  • suse-upgrade-libndr0-32bit
  • suse-upgrade-libndr1
  • suse-upgrade-libndr1-32bit
  • suse-upgrade-libnetapi-devel
  • suse-upgrade-libnetapi0
  • suse-upgrade-libnetapi0-32bit
  • suse-upgrade-libsamba-credentials-devel
  • suse-upgrade-libsamba-credentials0
  • suse-upgrade-libsamba-credentials0-32bit
  • suse-upgrade-libsamba-errors-devel
  • suse-upgrade-libsamba-errors0
  • suse-upgrade-libsamba-errors0-32bit
  • suse-upgrade-libsamba-hostconfig-devel
  • suse-upgrade-libsamba-hostconfig0
  • suse-upgrade-libsamba-hostconfig0-32bit
  • suse-upgrade-libsamba-passdb-devel
  • suse-upgrade-libsamba-passdb0
  • suse-upgrade-libsamba-passdb0-32bit
  • suse-upgrade-libsamba-policy-devel
  • suse-upgrade-libsamba-policy-python3-devel
  • suse-upgrade-libsamba-policy0
  • suse-upgrade-libsamba-policy0-32bit
  • suse-upgrade-libsamba-policy0-python3
  • suse-upgrade-libsamba-util-devel
  • suse-upgrade-libsamba-util0
  • suse-upgrade-libsamba-util0-32bit
  • suse-upgrade-libsamdb-devel
  • suse-upgrade-libsamdb0
  • suse-upgrade-libsamdb0-32bit
  • suse-upgrade-libsmbclient-devel
  • suse-upgrade-libsmbclient0
  • suse-upgrade-libsmbclient0-32bit
  • suse-upgrade-libsmbconf-devel
  • suse-upgrade-libsmbconf0
  • suse-upgrade-libsmbconf0-32bit
  • suse-upgrade-libsmbldap-devel
  • suse-upgrade-libsmbldap2
  • suse-upgrade-libsmbldap2-32bit
  • suse-upgrade-libtevent-util-devel
  • suse-upgrade-libtevent-util0
  • suse-upgrade-libtevent-util0-32bit
  • suse-upgrade-libwbclient-devel
  • suse-upgrade-libwbclient0
  • suse-upgrade-libwbclient0-32bit
  • suse-upgrade-samba
  • suse-upgrade-samba-ceph
  • suse-upgrade-samba-client
  • suse-upgrade-samba-client-32bit
  • suse-upgrade-samba-core-devel
  • suse-upgrade-samba-doc
  • suse-upgrade-samba-dsdb-modules
  • suse-upgrade-samba-kdc
  • suse-upgrade-samba-kdc-32bit
  • suse-upgrade-samba-libs
  • suse-upgrade-samba-libs-32bit
  • suse-upgrade-samba-libs-python3
  • suse-upgrade-samba-libs-python3-32bit
  • suse-upgrade-samba-pidl
  • suse-upgrade-samba-python
  • suse-upgrade-samba-python3
  • suse-upgrade-samba-test
  • suse-upgrade-samba-winbind
  • suse-upgrade-samba-winbind-32bit

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;