Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2018-20748: SUSE Linux Security Advisory

Back to Search

SUSE: CVE-2018-20748: SUSE Linux Security Advisory

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
01/30/2019
Created
03/19/2019
Added
02/12/2019
Modified
05/07/2019

Description

LibVNC before 0.9.12 contains multiple heap out-of-bounds write vulnerabilities in libvncclient/rfbproto.c. The fix for CVE-2018-20019 was incomplete.

Solution(s)

  • suse-upgrade-libvncclient0
  • suse-upgrade-libvncclient0-debuginfo
  • suse-upgrade-libvncserver
  • suse-upgrade-libvncserver-debugsource
  • suse-upgrade-libvncserver-devel
  • suse-upgrade-libvncserver0
  • suse-upgrade-libvncserver0-debuginfo
  • suse-upgrade-linuxvnc
  • suse-upgrade-linuxvnc-debuginfo

References

  • suse-upgrade-libvncclient0
  • suse-upgrade-libvncclient0-debuginfo
  • suse-upgrade-libvncserver
  • suse-upgrade-libvncserver-debugsource
  • suse-upgrade-libvncserver-devel
  • suse-upgrade-libvncserver0
  • suse-upgrade-libvncserver0-debuginfo
  • suse-upgrade-linuxvnc
  • suse-upgrade-linuxvnc-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;