Rapid7 Vulnerability & Exploit Database

SUSE: CVE-2018-9336: SUSE Linux Security Advisory

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

SUSE: CVE-2018-9336: SUSE Linux Security Advisory

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
05/01/2018
Created
07/25/2018
Added
07/07/2018
Modified
10/22/2021

Description

openvpnserv.exe (aka the interactive service helper) in OpenVPN 2.4.x before 2.4.6 allows a local attacker to cause a double-free of memory by sending a malformed request to the interactive service. This could cause a denial-of-service through memory corruption or possibly have unspecified other impact including privilege escalation.

Solution(s)

  • suse-upgrade-openvpn
  • suse-upgrade-openvpn-auth-pam-plugin
  • suse-upgrade-openvpn-devel
  • suse-upgrade-openvpn-down-root-plugin

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;