Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-2923-1 (CVE-2016-2510): BeanShell vulnerability

Back to Search

Ubuntu: USN-2923-1 (CVE-2016-2510): BeanShell vulnerability

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
03/08/2016
Created
07/25/2018
Added
04/07/2016
Modified
03/02/2020

Description

BeanShell (bsh) before 2.0b6, when included on the classpath by an application that uses Java serialization or XStream, allows remote attackers to execute arbitrary code via crafted serialized data, related to XThis.Handler.

Solution(s)

  • ubuntu-upgrade-bsh
  • ubuntu-upgrade-bsh-gcj
  • ubuntu-upgrade-libbsh-java

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;