Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-2980-1 (CVE-2016-3698): libndp vulnerability

Back to Search

Ubuntu: USN-2980-1 (CVE-2016-3698): libndp vulnerability

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
05/17/2016
Created
07/25/2018
Added
05/17/2016
Modified
04/25/2018

Description

libndp before 1.6, as used in NetworkManager, does not properly validate the origin of Neighbor Discovery Protocol (NDP) messages, which allows remote attackers to conduct man-in-the-middle attacks or cause a denial of service (network connectivity disruption) by advertising a node as a router from a non-local network.

Solution(s)

  • ubuntu-upgrade-libndp0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;