Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3455-1 (CVE-2016-4476): wpa_supplicant and hostapd vulnerabilities

Back to Search

Ubuntu: USN-3455-1 (CVE-2016-4476): wpa_supplicant and hostapd vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
05/09/2016
Created
07/25/2018
Added
10/16/2017
Modified
09/12/2020

Description

hostapd 0.6.7 through 2.5 and wpa_supplicant 0.6.7 through 2.5 do not reject \n and \r characters in passphrase parameters, which allows remote attackers to cause a denial of service (daemon outage) via a crafted WPS operation.

Solution(s)

  • ubuntu-upgrade-hostapd
  • ubuntu-upgrade-wpasupplicant

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;