Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-4774-1 (CVE-2016-9878): Spring Framework vulnerabilities

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Ubuntu: USN-4774-1 (CVE-2016-9878): Spring Framework vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
12/29/2016
Created
03/29/2023
Added
03/22/2023
Modified
03/22/2023

Description

An issue was discovered in Pivotal Spring Framework before 3.2.18, 4.2.x before 4.2.9, and 4.3.x before 4.3.5. Paths provided to the ResourceServlet were not properly sanitized and as a result exposed to directory traversal attacks.

Solution(s)

  • ubuntu-upgrade-libspring-aop-java
  • ubuntu-upgrade-libspring-beans-java
  • ubuntu-upgrade-libspring-context-java
  • ubuntu-upgrade-libspring-context-support-java
  • ubuntu-upgrade-libspring-core-java
  • ubuntu-upgrade-libspring-expression-java
  • ubuntu-upgrade-libspring-instrument-java
  • ubuntu-upgrade-libspring-jdbc-java
  • ubuntu-upgrade-libspring-jms-java
  • ubuntu-upgrade-libspring-orm-java
  • ubuntu-upgrade-libspring-oxm-java
  • ubuntu-upgrade-libspring-transaction-java
  • ubuntu-upgrade-libspring-web-java
  • ubuntu-upgrade-libspring-web-portlet-java
  • ubuntu-upgrade-libspring-web-servlet-java
  • ubuntu-upgrade-libspring-web-struts-java

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;