Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2017-0901): Ruby regression

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2017-0901): Ruby regression

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:P)
Published
08/31/2017
Created
07/25/2018
Added
10/05/2017
Modified
03/26/2021

Description

RubyGems version 2.6.12 and earlier fails to validate specification names, allowing a maliciously crafted gem to potentially overwrite any file on the filesystem.

Solution(s)

  • ubuntu-upgrade-libruby1-9-1
  • ubuntu-upgrade-libruby2-0
  • ubuntu-upgrade-libruby2-3
  • ubuntu-upgrade-ruby1-9-1
  • ubuntu-upgrade-ruby1-9-3
  • ubuntu-upgrade-ruby2-0
  • ubuntu-upgrade-ruby2-3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;