Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-4786-1 (CVE-2017-18214): Moment.js vulnerabilities

Free InsightVM Trial No credit card necessary
Watch Demo See how it all works
Back to Search

Ubuntu: USN-4786-1 (CVE-2017-18214): Moment.js vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
03/04/2018
Created
03/29/2023
Added
03/22/2023
Modified
03/22/2023

Description

The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.

Solution(s)

  • ubuntu-upgrade-libjs-moment
  • ubuntu-upgrade-node-moment

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;