Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3666-1 (CVE-2017-2592): Oslo middleware vulnerability

Back to Search

Ubuntu: USN-3666-1 (CVE-2017-2592): Oslo middleware vulnerability

Severity
2
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:N)
Published
05/08/2018
Created
07/25/2018
Added
06/12/2018
Modified
03/02/2020

Description

python-oslo-middleware before versions 3.8.1, 3.19.1, 3.23.1 is vulnerable to an information disclosure. Software using the CatchError class could include sensitive values in a traceback's error message. System users could exploit this flaw to obtain sensitive information from OpenStack component error logs (for example, keystone tokens).

Solution(s)

  • ubuntu-upgrade-python-oslo-middleware
  • ubuntu-upgrade-python-oslo-middleware-doc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;