Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3709-1 (CVE-2018-0499): Xapian-core vulnerability

Back to Search

Ubuntu: USN-3709-1 (CVE-2018-0499): Xapian-core vulnerability

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
07/02/2018
Created
07/25/2018
Added
07/17/2018
Modified
05/03/2019

Description

A cross-site scripting vulnerability in queryparser/termgenerator_internal.cc in Xapian xapian-core before 1.4.6 exists due to incomplete HTML escaping by Xapian::MSet::snippet().

Solution(s)

  • ubuntu-upgrade-libxapian30
  • ubuntu-upgrade-xapian-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;