Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2018-1000078): Ruby regression

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2018-1000078): Ruby regression

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
03/13/2018
Created
07/25/2018
Added
04/25/2018
Modified
09/12/2020

Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Cross Site Scripting (XSS) vulnerability in gem server display of homepage attribute that can result in XSS. This attack appear to be exploitable via the victim must browse to a malicious gem on a vulnerable gem server. This vulnerability appears to have been fixed in 2.7.6.

Solution(s)

  • ubuntu-upgrade-libruby1-9-1
  • ubuntu-upgrade-libruby2-0
  • ubuntu-upgrade-libruby2-3
  • ubuntu-upgrade-ruby1-9-1
  • ubuntu-upgrade-ruby1-9-3
  • ubuntu-upgrade-ruby2-0
  • ubuntu-upgrade-ruby2-3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;