Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3648-1 (CVE-2018-1000300): curl vulnerabilities

Back to Search

Ubuntu: USN-3648-1 (CVE-2018-1000300): curl vulnerabilities

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
05/16/2018
Created
07/25/2018
Added
05/23/2018
Modified
09/12/2020

Description

curl version curl 7.54.1 to and including curl 7.59.0 contains a CWE-122: Heap-based Buffer Overflow vulnerability in denial of service and more that can result in curl might overflow a heap based memory buffer when closing down an FTP connection with very long server command replies.. This vulnerability appears to have been fixed in curl < 7.54.1 and curl >= 7.60.0.

Solution(s)

  • ubuntu-upgrade-curl
  • ubuntu-upgrade-libcurl3
  • ubuntu-upgrade-libcurl3-gnutls
  • ubuntu-upgrade-libcurl3-nss
  • ubuntu-upgrade-libcurl4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;