Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2018-1000802): Python vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2018-1000802): Python vulnerabilities

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
09/18/2018
Created
03/19/2019
Added
11/15/2018
Modified
03/02/2020

Description

Python Software Foundation Python (CPython) version 2.7 contains a CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in shutil module (make_archive function) that can result in Denial of service, Information gain via injection of arbitrary files on the system or entire drive. This attack appear to be exploitable via Passage of unfiltered user input to the function. This vulnerability appears to have been fixed in after commit add531a1e55b0a739b0f42582f1c9747e5649ace.

Solution(s)

  • ubuntu-upgrade-python2-7
  • ubuntu-upgrade-python2-7-minimal
  • ubuntu-upgrade-python3-4
  • ubuntu-upgrade-python3-4-minimal
  • ubuntu-upgrade-python3-5
  • ubuntu-upgrade-python3-5-minimal

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;