Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2018-12697): GNU binutils vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2018-12697): GNU binutils vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
06/23/2018
Created
04/14/2020
Added
04/09/2020
Modified
04/23/2020

Description

A NULL pointer dereference (aka SEGV on unknown address 0x000000000000) was discovered in work_stuff_copy_to_from in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.30. This can occur during execution of objdump.

Solution(s)

  • ubuntu-upgrade-binutils
  • ubuntu-upgrade-binutils-multiarch
  • ubuntu-upgrade-libiberty-dev

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;