Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-4034-1 (CVE-2018-18544): ImageMagick vulnerabilities

Back to Search

Ubuntu: USN-4034-1 (CVE-2018-18544): ImageMagick vulnerabilities

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:P)
Published
10/20/2018
Created
06/27/2019
Added
06/25/2019
Modified
06/25/2019

Description

There is a memory leak in the function WriteMSLImage of coders/msl.c in ImageMagick 7.0.8-13 Q16, and the function ProcessMSLScript of coders/msl.c in GraphicsMagick before 1.3.31.

Solution(s)

  • ubuntu-upgrade-imagemagick
  • ubuntu-upgrade-imagemagick-6-q16
  • ubuntu-upgrade-libmagick-6-q16-5v5
  • ubuntu-upgrade-libmagick-6-q16-7
  • ubuntu-upgrade-libmagick-6-q16-8
  • ubuntu-upgrade-libmagickcore-6-q16-2
  • ubuntu-upgrade-libmagickcore-6-q16-2-extra
  • ubuntu-upgrade-libmagickcore-6-q16-3
  • ubuntu-upgrade-libmagickcore-6-q16-3-extra
  • ubuntu-upgrade-libmagickcore-6-q16-6
  • ubuntu-upgrade-libmagickcore-6-q16-6-extra

References

  • ubuntu-upgrade-imagemagick
  • ubuntu-upgrade-imagemagick-6-q16
  • ubuntu-upgrade-libmagick-6-q16-5v5
  • ubuntu-upgrade-libmagick-6-q16-7
  • ubuntu-upgrade-libmagick-6-q16-8
  • ubuntu-upgrade-libmagickcore-6-q16-2
  • ubuntu-upgrade-libmagickcore-6-q16-2-extra
  • ubuntu-upgrade-libmagickcore-6-q16-3
  • ubuntu-upgrade-libmagickcore-6-q16-3-extra
  • ubuntu-upgrade-libmagickcore-6-q16-6
  • ubuntu-upgrade-libmagickcore-6-q16-6-extra

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;