Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3591-1 (CVE-2018-7536): Django vulnerabilities

Back to Search

Ubuntu: USN-3591-1 (CVE-2018-7536): Django vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
03/06/2018
Created
07/25/2018
Added
04/25/2018
Modified
03/09/2021

Description

An issue was discovered in Django 2.0 before 2.0.3, 1.11 before 1.11.11, and 1.8 before 1.8.19. The django.utils.html.urlize() function was extremely slow to evaluate certain inputs due to catastrophic backtracking vulnerabilities in two regular expressions (only one regular expression for Django 1.8.x). The urlize() function is used to implement the urlize and urlizetrunc template filters, which were thus vulnerable.

Solution(s)

  • ubuntu-upgrade-python-django
  • ubuntu-upgrade-python3-django

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;