Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-4213-1 (CVE-2019-18679): Squid vulnerabilities

Back to Search

Ubuntu: USN-4213-1 (CVE-2019-18679): Squid vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
11/05/2019
Created
12/07/2019
Added
12/05/2019
Modified
01/22/2020

Description

An issue was discovered in Squid 2.x, 3.x, and 4.x through 4.8. Due to incorrect data management, it is vulnerable to information disclosure when processing HTTP Digest Authentication. Nonce tokens contain the raw byte value of a pointer that sits within heap memory allocation. This information reduces ASLR protections and may aid attackers isolating memory areas to target for remote code execution attacks.

Solution(s)

  • ubuntu-upgrade-squid
  • ubuntu-upgrade-squid3

References

  • ubuntu-upgrade-squid
  • ubuntu-upgrade-squid3

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;