Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2019-9636): Python vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2019-9636): Python vulnerabilities

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:N)
Published
03/08/2019
Created
09/11/2019
Added
09/10/2019
Modified
01/20/2021

Description

Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.

Solution(s)

  • ubuntu-upgrade-python2-7
  • ubuntu-upgrade-python2-7-minimal
  • ubuntu-upgrade-python3-4
  • ubuntu-upgrade-python3-4-minimal
  • ubuntu-upgrade-python3-5
  • ubuntu-upgrade-python3-5-minimal
  • ubuntu-upgrade-python3-6
  • ubuntu-upgrade-python3-6-minimal
  • ubuntu-upgrade-python3-7
  • ubuntu-upgrade-python3-7-minimal

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;