Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-5447-1 (CVE-2022-1348): logrotate vulnerability

Back to Search

Ubuntu: USN-5447-1 (CVE-2022-1348): logrotate vulnerability

Severity
4
CVSS
(AV:N/AC:L/Au:S/C:N/I:N/A:P)
Published
05/25/2022
Created
05/31/2022
Added
05/27/2022
Modified
06/09/2022

Description

A vulnerability was found in logrotate in how the state file is created. The state file is used to prevent parallel executions of multiple instances of logrotate by acquiring and releasing a file lock. When the state file does not exist, it is created with world-readable permission, allowing an unprivileged user to lock the state file, stopping any rotation. This flaw affects logrotate versions before 3.20.0.

Solution(s)

  • ubuntu-upgrade-logrotate

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;