Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2022-1882): Linux kernel (Intel IoTG) vulnerabilities

Back to Search

Ubuntu: (Multiple Advisories) (CVE-2022-1882): Linux kernel (Intel IoTG) vulnerabilities

Severity
7
CVSS
(AV:L/AC:L/Au:N/C:C/I:C/A:C)
Published
05/26/2022
Created
10/12/2022
Added
10/11/2022
Modified
10/28/2022

Description

A use-after-free flaw was found in the Linux kernel’s pipes functionality in how a user performs manipulations with the pipe post_one_notification() after free_pipe_info() that is already called. This flaw allows a local user to crash or potentially escalate their privileges on the system.

Solution(s)

  • ubuntu-upgrade-linux-image-5-15-0-1004-gkeop
  • ubuntu-upgrade-linux-image-5-15-0-1015-ibm
  • ubuntu-upgrade-linux-image-5-15-0-1016-raspi
  • ubuntu-upgrade-linux-image-5-15-0-1016-raspi-nolpae
  • ubuntu-upgrade-linux-image-5-15-0-1017-gke
  • ubuntu-upgrade-linux-image-5-15-0-1017-intel-iotg
  • ubuntu-upgrade-linux-image-5-15-0-1019-gcp
  • ubuntu-upgrade-linux-image-5-15-0-1019-kvm
  • ubuntu-upgrade-linux-image-5-15-0-1019-oracle
  • ubuntu-upgrade-linux-image-5-15-0-1021-aws
  • ubuntu-upgrade-linux-image-5-15-0-1021-azure
  • ubuntu-upgrade-linux-image-5-15-0-50-generic
  • ubuntu-upgrade-linux-image-5-15-0-50-generic-64k
  • ubuntu-upgrade-linux-image-5-15-0-50-generic-lpae
  • ubuntu-upgrade-linux-image-5-15-0-50-lowlatency
  • ubuntu-upgrade-linux-image-5-15-0-50-lowlatency-64k
  • ubuntu-upgrade-linux-image-aws
  • ubuntu-upgrade-linux-image-aws-lts-22-04
  • ubuntu-upgrade-linux-image-azure
  • ubuntu-upgrade-linux-image-azure-lts-22-04
  • ubuntu-upgrade-linux-image-gcp
  • ubuntu-upgrade-linux-image-generic
  • ubuntu-upgrade-linux-image-generic-64k
  • ubuntu-upgrade-linux-image-generic-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-64k-hwe-22-04
  • ubuntu-upgrade-linux-image-generic-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-hwe-22-04
  • ubuntu-upgrade-linux-image-generic-lpae
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-22-04
  • ubuntu-upgrade-linux-image-gke
  • ubuntu-upgrade-linux-image-gke-5-15
  • ubuntu-upgrade-linux-image-gkeop
  • ubuntu-upgrade-linux-image-gkeop-5-15
  • ubuntu-upgrade-linux-image-ibm
  • ubuntu-upgrade-linux-image-intel-iotg
  • ubuntu-upgrade-linux-image-kvm
  • ubuntu-upgrade-linux-image-lowlatency
  • ubuntu-upgrade-linux-image-lowlatency-64k
  • ubuntu-upgrade-linux-image-lowlatency-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-lowlatency-64k-hwe-22-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-20-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-22-04
  • ubuntu-upgrade-linux-image-oracle
  • ubuntu-upgrade-linux-image-raspi
  • ubuntu-upgrade-linux-image-raspi-nolpae
  • ubuntu-upgrade-linux-image-virtual
  • ubuntu-upgrade-linux-image-virtual-hwe-20-04
  • ubuntu-upgrade-linux-image-virtual-hwe-22-04

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;