Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2024-23254): WebKitGTK vulnerabilities

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Ubuntu: (Multiple Advisories) (CVE-2024-23254): WebKitGTK vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
03/08/2024
Created
04/16/2024
Added
04/16/2024
Modified
04/16/2024

Description

The issue was addressed with improved UI handling. This issue is fixed in tvOS 17.4, macOS Sonoma 14.4, visionOS 1.1, iOS 17.4 and iPadOS 17.4, watchOS 10.4, Safari 17.4. A malicious website may exfiltrate audio data cross-origin.

Solution(s)

  • ubuntu-upgrade-libjavascriptcoregtk-4-0-18
  • ubuntu-upgrade-libjavascriptcoregtk-4-1-0
  • ubuntu-upgrade-libjavascriptcoregtk-6-0-1
  • ubuntu-upgrade-libwebkit2gtk-4-0-37
  • ubuntu-upgrade-libwebkit2gtk-4-1-0
  • ubuntu-upgrade-libwebkitgtk-6-0-4

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;