Rapid7 Vulnerability & Exploit Database

Ubuntu: (Multiple Advisories) (CVE-2024-26697): Linux kernel vulnerabilities

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Ubuntu: (Multiple Advisories) (CVE-2024-26697): Linux kernel vulnerabilities

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
04/03/2024
Created
05/18/2024
Added
05/17/2024
Modified
06/06/2024

Description

In the Linux kernel, the following vulnerability has been resolved: nilfs2: fix data corruption in dsync block recovery for small block sizes The helper function nilfs_recovery_copy_block() of nilfs_recovery_dsync_blocks(), which recovers data from logs created by data sync writes during a mount after an unclean shutdown, incorrectly calculates the on-page offset when copying repair data to the file's page cache. In environments where the block size is smaller than the page size, this flaw can cause data corruption and leak uninitialized memory bytes during the recovery process. Fix these issues by correcting this byte offset calculation on the page.

Solution(s)

  • ubuntu-upgrade-linux-image-5-15-0-1044-gkeop
  • ubuntu-upgrade-linux-image-5-15-0-1054-ibm
  • ubuntu-upgrade-linux-image-5-15-0-1054-nvidia
  • ubuntu-upgrade-linux-image-5-15-0-1054-nvidia-lowlatency
  • ubuntu-upgrade-linux-image-5-15-0-1054-raspi
  • ubuntu-upgrade-linux-image-5-15-0-1057-intel-iotg
  • ubuntu-upgrade-linux-image-5-15-0-1058-gke
  • ubuntu-upgrade-linux-image-5-15-0-1058-kvm
  • ubuntu-upgrade-linux-image-5-15-0-1059-gcp
  • ubuntu-upgrade-linux-image-5-15-0-1059-oracle
  • ubuntu-upgrade-linux-image-5-15-0-106-generic
  • ubuntu-upgrade-linux-image-5-15-0-106-generic-64k
  • ubuntu-upgrade-linux-image-5-15-0-106-generic-lpae
  • ubuntu-upgrade-linux-image-5-15-0-106-lowlatency
  • ubuntu-upgrade-linux-image-5-15-0-106-lowlatency-64k
  • ubuntu-upgrade-linux-image-5-15-0-1061-aws
  • ubuntu-upgrade-linux-image-5-15-0-1063-azure
  • ubuntu-upgrade-linux-image-5-15-0-1063-azure-fde
  • ubuntu-upgrade-linux-image-5-4-0-1036-iot
  • ubuntu-upgrade-linux-image-5-4-0-1043-xilinx-zynqmp
  • ubuntu-upgrade-linux-image-5-4-0-1071-ibm
  • ubuntu-upgrade-linux-image-5-4-0-1084-bluefield
  • ubuntu-upgrade-linux-image-5-4-0-1091-gkeop
  • ubuntu-upgrade-linux-image-5-4-0-1108-raspi
  • ubuntu-upgrade-linux-image-5-4-0-1112-kvm
  • ubuntu-upgrade-linux-image-5-4-0-1123-oracle
  • ubuntu-upgrade-linux-image-5-4-0-1124-aws
  • ubuntu-upgrade-linux-image-5-4-0-1128-gcp
  • ubuntu-upgrade-linux-image-5-4-0-1129-azure
  • ubuntu-upgrade-linux-image-5-4-0-181-generic
  • ubuntu-upgrade-linux-image-5-4-0-181-generic-lpae
  • ubuntu-upgrade-linux-image-5-4-0-181-lowlatency
  • ubuntu-upgrade-linux-image-aws
  • ubuntu-upgrade-linux-image-aws-lts-20-04
  • ubuntu-upgrade-linux-image-aws-lts-22-04
  • ubuntu-upgrade-linux-image-azure
  • ubuntu-upgrade-linux-image-azure-cvm
  • ubuntu-upgrade-linux-image-azure-fde
  • ubuntu-upgrade-linux-image-azure-fde-lts-22-04
  • ubuntu-upgrade-linux-image-azure-lts-20-04
  • ubuntu-upgrade-linux-image-azure-lts-22-04
  • ubuntu-upgrade-linux-image-bluefield
  • ubuntu-upgrade-linux-image-gcp
  • ubuntu-upgrade-linux-image-gcp-lts-20-04
  • ubuntu-upgrade-linux-image-gcp-lts-22-04
  • ubuntu-upgrade-linux-image-generic
  • ubuntu-upgrade-linux-image-generic-64k
  • ubuntu-upgrade-linux-image-generic-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-hwe-18-04
  • ubuntu-upgrade-linux-image-generic-hwe-20-04
  • ubuntu-upgrade-linux-image-generic-lpae
  • ubuntu-upgrade-linux-image-generic-lpae-hwe-20-04
  • ubuntu-upgrade-linux-image-gke
  • ubuntu-upgrade-linux-image-gke-5-15
  • ubuntu-upgrade-linux-image-gkeop
  • ubuntu-upgrade-linux-image-gkeop-5-15
  • ubuntu-upgrade-linux-image-gkeop-5-4
  • ubuntu-upgrade-linux-image-ibm
  • ubuntu-upgrade-linux-image-ibm-lts-20-04
  • ubuntu-upgrade-linux-image-intel-iotg
  • ubuntu-upgrade-linux-image-kvm
  • ubuntu-upgrade-linux-image-lowlatency
  • ubuntu-upgrade-linux-image-lowlatency-64k
  • ubuntu-upgrade-linux-image-lowlatency-64k-hwe-20-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-18-04
  • ubuntu-upgrade-linux-image-lowlatency-hwe-20-04
  • ubuntu-upgrade-linux-image-nvidia
  • ubuntu-upgrade-linux-image-nvidia-lowlatency
  • ubuntu-upgrade-linux-image-oem
  • ubuntu-upgrade-linux-image-oem-20-04
  • ubuntu-upgrade-linux-image-oem-20-04b
  • ubuntu-upgrade-linux-image-oem-20-04c
  • ubuntu-upgrade-linux-image-oem-20-04d
  • ubuntu-upgrade-linux-image-oem-osp1
  • ubuntu-upgrade-linux-image-oracle
  • ubuntu-upgrade-linux-image-oracle-lts-20-04
  • ubuntu-upgrade-linux-image-oracle-lts-22-04
  • ubuntu-upgrade-linux-image-raspi
  • ubuntu-upgrade-linux-image-raspi-hwe-18-04
  • ubuntu-upgrade-linux-image-raspi-nolpae
  • ubuntu-upgrade-linux-image-raspi2
  • ubuntu-upgrade-linux-image-snapdragon-hwe-18-04
  • ubuntu-upgrade-linux-image-virtual
  • ubuntu-upgrade-linux-image-virtual-hwe-18-04
  • ubuntu-upgrade-linux-image-virtual-hwe-20-04
  • ubuntu-upgrade-linux-image-xilinx-zynqmp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;