Rapid7 Vulnerability & Exploit Database

Ubuntu: USN-3156-2: APT regression

Back to Search

Ubuntu: USN-3156-2: APT regression

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
12/16/2016
Created
07/25/2018
Added
12/19/2016
Modified
08/05/2020

Description

USN-3156-1 fixed vulnerabilities in APT. It also caused a bug in unattended-upgrades on that may require manual intervention to repair.

Users on Ubuntu 16.10 should run the following commands at a terminal:

sudo dpkg --configure --pending sudo apt-get -f install

This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

Jann Horn discovered that APT incorrectly handled InRelease files. If a remote attacker were able to perform a man-in-the-middle attack, this flaw could potentially be used to install altered packages.

Solution(s)

  • ubuntu-upgrade-apt

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;