Rapid7 Vulnerability & Exploit Database

VideoLAN-SB-VLC-308: Multiple vulnerabilities fixed in VLC media player

Back to Search

VideoLAN-SB-VLC-308: Multiple vulnerabilities fixed in VLC media player

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/18/2019
Created
09/14/2019
Added
09/13/2019
Modified
09/13/2019

Description

lavc_CopyPicture in modules/codec/avcodec/video.c in VideoLAN VLC media player through 3.0.7 has a heap-based buffer over-read because it does not properly validate the width and height.

Solution(s)

  • videolan-vlc-upgrade-3_0_8

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;