Vulnerability Database

The Rapid7 Vulnerability Database is a list of 70,000 vulnerabilities for security analyst and researchers to identify and address known security issues through vulnerability management solutions. Each vulnerability has links to relevant groups like Mitre and other CVE Numbering Authorities as well as additional technical documentation. These vulnerabilities are utilized by our vulnerability management tool Nexpose and provided here for additional visibility.


Displaying vulnerability details 71 - 80 of 135600 in total

Debian: CVE-2018-18314: perl -- security update Vulnerability

  • Severity: 4
  • Published: November 29, 2018

Details for this vulnerability have not been published by NIST at this point. Descriptions from software vendor advisories for this issue are provided below.

From DSA-4347:

Multiple vulnerabilities were discovered in the implementation of the

Perl programming language. The Common Vulnerabilities and Expos...

Debian: CVE-2018-18312: perl -- security update Vulnerability

  • Severity: 4
  • Published: November 29, 2018

Details for this vulnerability have not been published by NIST at this point. Descriptions from software vendor advisories for this issue are provided below.

From DSA-4347:

Multiple vulnerabilities were discovered in the implementation of the

Perl programming language. The Common Vulnerabilities and Expos...

Alpine Linux: CVE-2018-14626: pdns Multiple vulnerabilities Vulnerability

  • Severity: 4
  • Published: November 29, 2018

PowerDNS Authoritative Server 4.1.0 up to 4.1.4 inclusive and PowerDNS Recursor 4.0.0 up to 4.1.4 inclusive are vulnerable to a packet cache pollution via crafted query that can lead to denial of service.

Debian: CVE-2018-18313: perl -- security update Vulnerability

  • Severity: 4
  • Published: November 29, 2018

Details for this vulnerability have not been published by NIST at this point. Descriptions from software vendor advisories for this issue are provided below.

From DSA-4347:

Multiple vulnerabilities were discovered in the implementation of the

Perl programming language. The Common Vulnerabilities and Expos...

Ubuntu: USN-3795-3: libssh regression Vulnerability

  • Severity: 4
  • Published: November 29, 2018

USN-3795-1 and USN-3795-2 fixed a vulnerability in libssh. The upstream

fix introduced a regression. This update fixes the problem.

Original advisory details:

Peter Winter-Smith discovered that libssh incorrectly handled

authentication when being used as a server. A remote attacker could use

Alpine Linux: CVE-2018-10851: pdns Multiple vulnerabilities Vulnerability

  • Severity: 4
  • Published: November 29, 2018

PowerDNS Authoritative Server 3.3.0 up to 4.1.4 excluding 4.1.5 and 4.0.6, and PowerDNS Recursor 3.2 up to 4.1.4 excluding 4.1.5 and 4.0.9, are vulnerable to a memory leak while parsing malformed records that can lead to remote denial of service.

Wireshark : CVE-2018-19626 : DCOM dissector crash Vulnerability

  • Severity: 4
  • Published: November 28, 2018

In Wireshark 2.6.0 to 2.6.4 and 2.4.0 to 2.4.10, the DCOM dissector could crash. This was addressed in epan/dissectors/packet-dcom.c by adding '\0' termination.

Wireshark : CVE-2018-19628 : ZigBee ZCL dissector crash Vulnerability

  • Severity: 4
  • Published: November 28, 2018

In Wireshark 2.6.0 to 2.6.4, the ZigBee ZCL dissector could crash. This was addressed in epan/dissectors/packet-zbee-zcl-lighting.c by preventing a divide-by-zero error.

Wireshark : CVE-2018-19622 : MMSE dissector infinite loop Vulnerability

  • Severity: 4
  • Published: November 28, 2018

In Wireshark 2.6.0 to 2.6.4 and 2.4.0 to 2.4.10, the MMSE dissector could go into an infinite loop. This was addressed in epan/dissectors/packet-mmse.c by preventing length overflows.