Back to search

Java CPU June 2012 Java Runtime Environment Deployment vulnerability (CVE-2012-0551)

Severity CVSS Published Added Modified
6 (AV:N/AC:M/Au:N/C:P/I:P/A:N) May 03, 2012 June 19, 2012 December 04, 2013

Description

Unspecified vulnerability in the Java Runtime Environment (JRE) in Oracle Java SE 7 update 4 and earlier and 6 update 32 and earlier, and the GlassFish Enterprise Server component in Oracle Sun Products Suite GlassFish Enterprise Server 3.1.1, allows remote attackers to affect confidentiality and integrity via unknown vectors related to Web Container or Deployment.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

  • Oracle JRE >= 1.6.0.0 and < 1.6.0.33

    Upgrade to Oracle Java version 1.6.0.33

    Upgrade your copy of the Java Runtime Environment to 1.6.0.33, which can be downloaded from here.

  • Oracle JRE >= 1.7.0.0 and < 1.7.0.5

    Upgrade to Oracle Java version 1.7.0.5

    Upgrade your copy of the Java Runtime Environment to 1.7.0.5, which can be downloaded from here.

Related Vulnerabilities