Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2021-22940: Important: nodejs:12 security and bug fix update (Multiple Advisories)

Back to Search

Alma Linux: CVE-2021-22940: Important: nodejs:12 security and bug fix update (Multiple Advisories)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
08/16/2021
Created
05/05/2022
Added
05/04/2022
Modified
05/13/2022

Description

Node.js before 16.6.1, 14.17.5, and 12.22.5 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Solution(s)

  • alma-upgrade-nodejs
  • alma-upgrade-nodejs-devel
  • alma-upgrade-nodejs-docs
  • alma-upgrade-nodejs-full-i18n
  • alma-upgrade-nodejs-nodemon
  • alma-upgrade-nodejs-packaging
  • alma-upgrade-npm

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;