Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2022-24806: Improper Input Validation

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Alpine Linux: CVE-2022-24806: Improper Input Validation

Severity
7
CVSS
(AV:N/AC:L/Au:S/C:N/I:C/A:N)
Published
04/16/2024
Created
06/11/2024
Added
06/06/2024
Modified
06/11/2024

Description

net-snmp provides various tools relating to the Simple Network Management Protocol. Prior to version 5.9.2, a user with read-write credentials can exploit an Improper Input Validation vulnerability when SETing malformed OIDs in master agent and subagent simultaneously. Version 5.9.2 contains a patch. Users should use strong SNMPv3 credentials and avoid sharing the credentials. Those who must use SNMPv1 or SNMPv2c should use a complex community string and enhance the protection by restricting access to a given IP address range.

Solution(s)

  • alpine-linux-upgrade-net-snmp

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;